リリースノート - Version 1.X

* は変更/不具合修正を意味しています。

+ は追加事項です。

− は削除された事項です。

Version 1.9.0 2010-05-25 リリース

+ "Force login" を実装(Setup/console/global settings)。

注1: Force login=off で新しいショーを開始した場合、デフォルトで(guest ではなく) administrator としてログインされます。Force login=on の場合、デフォルトでは guest としてログインされます。ユーザ名とパスワードによってユーザを切り替えられます(Tools/Login)。

注2: ネットワークでショーを開始した場合、ログインポップアップは動作しません。

+ ユーザ権限を実装。

注: "guest" ユーザは「再生」だけが許されています。以前 "guest" プロファイルだったすべてのショーは、"administrator" に変換されます。"guest" ユーザによって作成されたマクロは、正しく動作しません。このバージョンでは、"preset" および "none" 権限はまだ利用できません。

+ Sequence Executor シート: A および B 欄は破棄され、列モードになりました。これによって通常の "assert" が可能になります(アサート値が保存されたキューからのタイムを利用)。 "x-assert" (アサート値に現在キューのタイミングを適用)。 "break" では、値を "cue only" として扱います。これはトラッキングリストを中断させます。 "x-break" ("x-assert" と同じタイミングで動作)。

注1: "break" はアサート機能を含みます。

注2: 以前のキューで後から保存された値は、"break" として設定されたキューによって解除されます。

注3: このバージョンにおける既知の制限: 元の値を見つける際に、元内容の更新は Break を無視します。これらの更新された値が "Break" キューへとトラッキングする場合、上述のように扱われ、更新された現在のキューへはトラッキングしません。

注4: Tracking シート編集でも Break は無視されます。

+ 状態をともなうキュー/キューのみのコピーが実装されました。

注: "copy cue" ではすべてのパートキューがコピーされます。

+ キュー遷移プロファイル(パス)のエンジンが完全に実装されました。

注: パスは、キュー/パートキューにおけるすべてのパラメータに対して働きます(grandMA シリーズ1 では、dimPath および movePath としてのみ動作)。

+ Playback に "Action Buttons" を追加。

注1: トップバーの "Direct Action" が有効な場合、ボタンのシンボル全体が実際のボタンのように振る舞います。

注2: ボタンビューは、マルチタッチに対応しています。

+ Speed Mode を実装(setup/user/settings)。

+ A/Bクロスフェードを実装。"Split X-fade" はデフォルトに設定。

注: "Split X-fade" と "AB X-fade" の設定は、通常のクロスフェードにも影響します。

+ エフェクトがスピード・グループを持ちます。

+ 100mmフェーダにスピード・グループを割り当てられます。

+ DMX List を実装(setup/show/patch only)。

注1: ユニバース一覧では、DMX入力をマージしたり、どのユニバースが現在のパラメータ数によって算出されるかを割り当てたりできます。

注2: 右側にはチャンネル毎のDMXパッチが表示され、それらに直接プロファイルを割り当てることができます(粗のみ)。(grandMA シリーズ1の DMX List では、プロファイルを割り当てられるのはパラメータに対してのみ)

注意: プロファイルをパラメータとDMXチャンネルに同時に割り当てると、両方の設定が無効になるかもしれません。

注3: 見出し部分を右クリックすると列ごとにソートされます。

+ Specialized Color ダイアログの HSB および Fader ビューに、Align 機能を実装。

注: HSB ビューでは、明度が十字マークの変化で表示されます。異なる色のフィクスチャは独自のマーカを持ちます。

+ Setup で複数のブレーク(DMXスタートアドレス)を持つフィクスチャを追加した場合、フィクスチャウィザードに追加のパッチ行が出ます。

+ 高速 MA-net が可能になりました。

注: 卓の電源投入時に、ネットワークカードが現在の状態(100MB/1GB)を決めます。ネットワークのスピードは、セッション開始時に最も遅いものに決まります。これは、コマンドラインで "ni" (networkinfo)コマンドによって確認できます。

+ Setup 編集のタイトルバーに、使用可能/使用パラメータの数が表示されます。

+ エクゼキュータ・ボタンは Temp ボタンとして割り当てられるようになりました。

注: アクティブな Off On Overwritten は無視されません(シリーズ1のように)。

+ コマンドライン履歴が実装されました。モニタ画面1または2のコマンドラインにフォーカスがある場合、キーボードの上下ボタンを使えます。

+ 新しいショーファイルを読み込む前に古いものを保存するかの確認ボックス。

+ 卓の電源を切る際のショー自動保存は、ショーファイルに変更がある場合のみ行われます(ビューの呼び出しやページ変更のみの場合は、保存しません)。

+ MA NPU (Network Processing Unit) がメモリ使用量をメイン画面に表示するようになりました。

+ パッチの不整合を確認できるようにしました。

+ フィクスチャIDおよびチャンネルIDの不整合を確認できるようにしました。

+ パッチ・ダイアログにマルチパッチを実装。

+ パッチ・ダイアログにおいて、PLEASE キーによる選択の迅速化。

+ Telnet 接続の際に安全のためログインが必要になりました(ユーザ・ログインデータを使用)

+ Telnet が、コマンドラインからの要求に対応。

+ キューのみの削除を実装。

+ キューパートを削除する方法を実装。

注: パートの削除によって、値をデフォルト・パートへ移動することもできます。

+ Startup マクロ行を実装(Setup/Show/Playback + MIB Timings)

注: これらのマクロは、ショー読み込み時に実行されます。

+ Store Options に "DMX-IN" を追加。

+ Sequence Executor シートはコマンドラインと相互作用します。

注1: キュー行に対して store/ label/ del ハードキーを直接使用できます。

注2: この相互作用は、Sequence Executor シートにおいてのみ働きます。

+ ASCIIショーの読込: grandMA シリーズ1 でエクスポートされたファイルの読み込みおよび変換。

+ Backup/Load Show: ショー、バックアップあるいはその両方の選択。

注: "Save Show" によって、名前が .backup で終わるショーファイルに対して1個のバックアップが作られます。

付記:ファイル名の末尾が .x.backup という10個までのバックアップを作れます(x = 1〜10)。

+ Off メニューで、エフェクトをオフにできるようになりました。

+ タッチ画面を無効にできるようにしました(setup/console/screen options)。

+ 新しいソフトウェアのインストーラでは、卓/MA NPU の記憶容量を調べ、古いソフトウェア・バージョンを削除できます。

注: 直前の卓設定(IPアドレスなど)が必要なため、最新ソフトウェア・バージョンは削除できません。

+ VPU のレイヤを卓から選択できるようになりました(setup/network/MA network configuration/video)。

注: この操作は、コマンドラインからはできません。

+ 3Dのユーザを卓から切り替えられるようになりました(Setup/Network/MA Network Configuration/Visualizer)。

+ プリセット・プールにおいて、特殊プリセットがマークされます。

注1: "assign preset x.y /special=z" というコマンドで特殊プリセットを作成できます。変数 z: 0=normal、1=default、2=highlight、3=stage (3は未実装)。

注2: これらのプリセットは、Setup において、フィクスチャ/チャンネル・デフォルト/ハイライト値を直接変更します。

注3: 特殊プリセットを作成するための新しい定義済みマクロがあります。

+ Sequence Executor シートの MIB欄を編集すると、"Select MIB" ポップアップが開きます。

注1: 既知の制限: "late" は、完全な番号を持つキューにおいてのみ動作します(1.1 や 2.3 というようなキューでは動作しません)。

注2: 既知の制限:トラッキング・シーケンスでないものに対しては動作しません。

+ Oops の履歴一覧を実装しました(Ooops ボタンを長押し)。

注1: ポップアップの行を選択することによって、一度に複数のやり直しを行うことができます。

注2: 保存によって "patch & fixture schedule" から抜けると、Oops 一覧はクリアされます。

+ "Trackball Mode" をユーザのデフォルトとして設定できます(setup/user/settings)。

+ Diagnostics ポップアップを実装(Setup/Patch & Fixture Schedule)。これは、現在の範囲に対する警告/エラーのレポートを表示します。

注: 設定から抜ける際に、警告があると選択メニューが出ます。

+ プリセットおよびエクゼキュータ・ボタンに対する "Manual x-fade" を実装(エンコーダ・バー)

注1: プリセットに対する "set time" や "manual x-fade" 機能を有効にしていると、セレクトされているフィクスチャのアトリビュート番号が表示されます。エクゼキュータ・ボタンに対する "manual x-fade" 機能を有効にしていると、事前に押されていた別のボタンの番号が表示されます。対応するエクゼキュータ・ボタンのLEDが点滅します。

注2: 今のところこのタイミングは、カラー・ピッカーにたいしては働きません。

注3: プリセット・タイムは、エフェクト以外のすべてのプログラマ動作に対して働きます。

+ 定義済みプロファイルを実装(Setup/Patch & Fixture Schedule/DMX Profiles/Edit Profile)。

+ Timecode Editor: "Add Track"、"Change Executor" および "Add Subtracks"(Track Functions) ボタンを追加。

注: "Delete Track" ボタンはサブトラックも削除します。コマンドでサブトラックが選択されていると[最初のサブトラック]、そのトラック全体が削除されます。そうでない場合は、選択されているサブトラックのみが削除されます。

+ Timecode Editor の Text モード: タイムコード・グリッドでの範囲選択を追加。

+ "DMX at" を実装(grandMA シリーズ1と同様)。

+ フィクスチャ・ライブラリを更新(carallon lib 6.2 から)。

+ カラー・ライブラリを更新。

注: カラー・ライブラリは、新しい空のショーからのみ再インポートされます。古いショーファイルを使うには、コマンドラインで cd 9, delete *, import swatchbook, cd/。

+ Fixture シートで、1つのフィクスチャに対して16個のアトリビュートを表示できるようになりました(以前のバージョンでは8)。

+ プリセット・プールのオプション・メニューに "Reset Colour" ボタンを追加(setup/user/window settings/presets/... と同様)。

* フィクスチャレイヤを削除してショーファイルを保存した際に、ショーファイルが壊れないようになりました。

* ショーのアップロード/ダウンロードおよびショーファイル保存の状態のプログレスバー表示が改善されました。

* 自動シャットダウン・ポップアップはタッチ画面で確定しなければなりません。キーボードの Please ボタンで誤って確定してしまうことはありません(ポップアップに自動的にフォーカスが移りません)。

* Backup / new Show において、仮想キーボードを閉じても、直ちに新しいショーが作成されないようになりました。

* キューのリナンバー・ポップアップにおいて、数字キーも動作するようになりました。

* "ifoutput" をビットマップ・エフェクトと組み合わせると卓がクラッシュする不具合を修正。

* ループ機能が、タイムトリガーによるキューに対しても動作するようになりました。

* パートキューをともなう Content シートで卓がクラッシュする不具合を修正。

* Sequence Executor シートで Fade バーを削除するとクラッシュする不具合を修正。

* ネットワークで Temp フェーダが動作します。

* Content シート: エクゼキュータを直接(リンクではなく) 手動モードに割り当てても動作するようになりました。

* 古いショーファイルからの相対エフェクトは絶対としてインポートされます。

* Save Show および Quicksave で自動保存のタイマーがリセットされるようになりました。

* Playback ビューでランダムな枠色になってしまうのを修正。

* Sequence Executor シートにおいて、ループ機能によるキュー・ジャンプが、正しい色を表示するようになりました。

* Setup/Show/Playbacktiming: タイムは秒で表示されます。

* Specialized Color ダイアログにおいて、RGB または CMY がすべて "100" の場合もフェーダが動作するようになりました。

* 100mmフェーダで "X fade reload=off" が動作するようになりました。

* Tracking シートにおいて、キュー番号と名前を変更できるようになりました。

* onPC: エンコーダの設定がモニタ画面1に表示されます。

* ライブ・アクセスでフィクスチャ名を変更すると、"vertical mode" の Fixture シートに反映されます。

* スピード・グループで Learn ボタンが再び動作するようになりました。

* Graph Editor で、ポイントの動きを現在の値範囲内に制限するようにしました。これは、DMXプロファイルのポイントを表示範囲の外へはドラッグできないことを意味します。

* ビデオ制御のための Smart ビュー: エンコーダで i プールを変更した際に、イメージのビューが更新されます。

* カラーピッカーで画面エンコーダが動作します。

* Special Effect ダイアログ(マルチタッチ)に "Sync Effects" ソフトボタンが表示されます。

* Backup メニュー: 古いソフトウェアバージョンからショーファイルを削除できるようになりました。

* Fixture シートでフィクスチャID番号を右クリックすると、フィクスチャ編集ポップアップが開きます。

* 新しいショーをロードする際に、空のエクゼキュータが固定しなくなりました。

* Timecode Editor: タイムコード同期モードが "Intern" の場合、"User Bits" と "Auto Start" のみが無効になります。

* Timecode Editor の Text モード: Value 欄にキュー番号と名前が表示されます。

* フィクスチャをオフにすると、Channel および fixture シートが更新されます(Prog. Only オプション)。

変更:

* "Xfade Reload" を、全エクゼキュータの Assign メニューから、デフォルトに移動しました(Setup/Show/Playback+MIB Timing)。

* ナイトライダー・エフェクトは外されました(卓のロック状態)。

既知の不具合および制限:

− grandMA2による MA 2Port Node のリモート設定は、ノードのディスプレイには正しく表示されますが、実際の出力が変更されません。ノードのリセット(電源再投入)後に反映されます。

− 2つ以上のモードチャンネルを持つフィクスチャタイプは動作しません。

Version 1.8.0 2010-04-12 リリース

+ MIB列にMIB実行キューを入力できる Move in Black (MIB)。 付加オプション: "Early" / "Late" / "-x" / "x" (キュー) (MIB動作中のエクゼキュータ・ボタンLEDの点滅: 速 = MIB ディレイタイム、遅 = MIB フェードタイム)

注意: 最初のMIBは、前にゼロのディマー値を保存しなくても動作します(grandMA シリーズ1では必要でした)。

+ "restart first cue" と "restart next cue" とあせて、"temp fader" と "temp master fader" が実装されました。

注意: "temp fader" は、スナップ・アトリビュートもフェードさせます。"x-fader" は、スナップ・アトリビュートを切り替えます。

+ Fixture エディタを、"Module Manager"、"Wheel Manager"、"Instance Manager" に分けました。

+ 新しいサブアトリビュートを持つ Attribute & Encoder Grouping。"Encoder Grouping" 列は名前を含みます。

+ 新キーワード: "ShuffleSelection" (定義済みマクロにも有り)。

+ 新キーワード: "ClearActive" (Clear×2、定義済みマクロにも有り)。

+ 新キーワード: CmdHelp (全キーワードの概観)。

+ 新キーワード: "Layer Value"、"Layer Fade"、"Layer Delay"、"Layer EffectForm"、"Layer EffectRate"、"Layer EffectValue1"、"Layer EffectValue2"、"Layer EffectPhase"、"Layer EffectWidth"。

+ Setup/Show に Playback および MIB のデフォルト。新しい >>> + <<< タイミング GoFast (デフォルトのタイミングはショーファイルに保存)。

+ エフェクトで "Absolute"、"Relative" および "Transparent" が可能になりました。Effect Editor では、新しい列に表示されます。またエフェクト・プールでは、エフェクトの見出しに A、R、T と表示されます。

2種類のエクゼキュータがあるとします。エクゼキュータ1には、ステージ上の定位置にあるビームが割り当てられています。エクゼキュータ2には、サークル・エフェクトが割り当てられています(直接割り当てられたエフェクトではない、キューリスト形式)。

通常モード(Absolute または Relative)での動作:

a) まずエクゼキュータ1を開始し、それがエクゼキュータ2によって上書きされた場合、デフォルトでは、上書きによって、エクゼキュータ1のステージ位置ではなく、その中央位置のまわりでビールがサークルを描きます。

b) まずエクゼキュータ2を開始し、それがエクゼキュータ1によって上書きされた場合、デフォルトでは、エフェクトが上書きされるため、サークルが停止し、ビームはステージ上の定位置に動きます。

Transparent モードでの動作:

a) サークル・エフェクトは、エクゼキュータ1のステージ位置に対して透過的になっているので、異なった動きになります。

エクゼキュータ2が高優先度に設定されている場合、他の通常のものやこの透過動作の低優先度のエクゼキュータに対してオーバーレイするため、b) の場合にも異なった動きになります。

注意: 透過性は、さまざまな再生の間にエフェクトと値がどう関連付けられるかを定めます。

+ キューに含まれていなくても、そのエフェクトが使用している現在のフィクスチャ番号を、Effect プールで表示するようにしました。フィクスチャセレクションがあり、そのエフェクトがオフの場合、これらのフィクスチャのいずれもオフにできます。フィクスチャセレクションが無い場合は、"off effect x" でエフェクト全体がオフになります。

+ プリセットバーに新しいエフェクト・ボタン。

+ ホイール・ボタンを押し下げると、エンコーダやホイールの分解能を変更したり、画面をクリアしたりするためのポップアップが開きます。

+ Setup に新しいパッチ・ダイアログ。

+ Fixture、Channel、Tracking シート: プリセット値を、それらの名前や番号で表示できるようになりました(オプションで設定可能)。

+ "On"、"Off"、"Park" および "Unpark" コマンドが、アトリビュート・エンコーダバーのフィーチャ欄と結び付いて動作するようになりました。

+ DMX入力のマージ: 2つのDMX入力ユニバースを、HTPでマージして出力できるようになりました。DMX入力は、ネットワーク内のさまざまな卓や MA NPU に接続できます。

既知の制限: 今のところ MA 2Port Node では動作しません。2以上のユニバースが接続されている場合、最初の2つが用いられ、他はすべて無視されます。

+ 新しいプリセット形式: Global "Selective" は、個別のフィクスチャの値を保存します。"Global" は、フィクスチャタイプの値を保存します。"Universal" は、現在保存されているアトリビュートを持つすべてのフィクスチャタイプの値を保存します。

注意1: "Universal" は、Dimmer、Pan、Tilt、RGB、CMY アトリビュートに対してのみ働きます(ステージ位置 xyz については後に実装)。

注意2: プリセットやエフェクトにも "Universal" があるため、grandMA シリーズ1の "Universal" は、"global" に変更されました。

+ Loop は、キューのトラッキング状態を呼び出すようになりました(Goto x と同様)。

+ Assign メニュー: オプション・ボタンを再編成、MIB Never を追加。

+ Swatch Book の特殊ダイアログに新機能: "Clear Filter"、"Live Preview"。

+ Midiリモート: エクゼキュータ・フェーダにベロシティが効くようになりました。

注1: Auto Start = on、Auto Stop = on の場合、ベロシティによってフェーダは100%(ベロシティ=127)になります。ベロシティが "0" になると、フェーダはそのままですがエクゼキュータはオフになります。Auto Start = on、Auto Stop = off の場合は、ベロシティによって、エクゼキュータはオンのまま上下します。

注2: 入力されたMIDIノートとそのベロシティは、System Monitor で見ることができます。

+ "Auto Stop" に対する "Fast Off" が実装されました。

注意: マスターフェーダを 0 に下げた際に、エクゼキュータのOffタイムは無視されます(Auto Stop = on)。マスターフェーダが0以上の場合、最初のオフではオフ・タイムが用いられ、次のオフでは直ちにエクゼキュータがオフになります。

+ エフェクトのインポート/エクスポートが実装されました。

注: コマンドラインによるエクスポート: "sd 3" (SelectDrive) に続けて "Export effect x thru y "フォルダ名"。インポート: "sd 3" (SelectDrive) に続けて "cd effect" (ハードディスクのエフェクト・フォルダに移動)、そして "import *"

+ ファームウェアをアップデート 1.28 (新しい卓でのLEDの明るさ調節)。

+ grandMA2 onPC で、アダプタに ArtNet IPアドレスを自動的・一時的に追加(定義されていない場合)。

* フェーダウィングのポジションが卓に保存されるようになりました。

* "x fader" や "TempFader" によってキューが開始された場合、"Load cue" は、トラッキング・キューの状態をロードするようになりました。

* キューを削除したり新たにマージしたりしても、タイムコード・リンクが混乱しないようになりました。

* 数値ブロックによるコマンドの入力 >Channel x full<、>time time 0 thru 5< が、正しく動作するようになりました。

* "At Filter View" が、内部マウス・コントロールに対応するようになりました。

* Backup メニューで、ファイル名を、シンボル、一覧、詳細として表示できるようにしました。

* ビューボタンにあるビューのラベルは、既存の名前を表示するようになりました。

* 28以上のチャンネルセットを持つアトリビュートに対して電卓を開くと、スクロールバーが出るようになりました。

* Edit Chaser で、チェイサー再生バーをエンコーダに持ってきます。

* MA NPU を含むショーのロード → アクティブなシーケンスが出力。

* 外部タイムコードをテキストモードで表示している場合に卓がクラッシュしないようになりました。

* Effect Editor が開いているときにエフェクトを削除しても卓がクラッシュしないようになりました。

* チェイサー・エフェクト実行中のフィクスチャをフラッシュした場合、正しいタイミングで動作するようになりました。

* マクロ行で、+、- および thru が数字キーパッドから動作するようになりました。

* 現在のワールドからフィクスチャを削除した場合、Fixture シートが更新されるようになりました。

* Fixture x at fixture y で、キューリストから開始されたエフェクトもコピーするようにしました。

* エクゼキュータに直接割り当てられたエフェクトが、Go- でも開始できるようになりました。

* Fixture シート: "Values only" レイヤが、チャンネルセットを表示しないようになりました。

* フォルダ構造の変更により、リモートの On/Off を切り替える定義済みマクロを修正しました。

* "Phase From" と "Phase To" が同じ値のエフェクトが動作するようになりました。

* 不正なファイル名のショーを保存しても、ネットワークがクラッシュしないようになりました。

* エフェクトの低いレートでの逆実行が正しく動作するようになりました。

* DMXリモートのプログラマへの入力が再び動作するようになりました。

* Effect Editor で複数選択が可能になりました(Ctrlを使用)。

* 値らしいフィクスチャを構築する際に、複数のダミー・チャンネルが可能になりました。

* Freeze モードにある Off メニューのバグを修正。

* 特殊エフェクト・ダイアログで、"default width" 値が正しく表示されるようになりました。

情報:

MA NPU を grandMA1 互換モードで MA 4Port Node として用いる場合、MA NPU のソフトウェアバージョンも最新のものにアップデートする必要があります。

新しいライブラリのすべてのRGBフィクスチャには RGB アトリビュートがありません。それらは、反転されたCMYフィクスチャに変換されます。新たにフィクスチャを作成し、実際または仮想ディマーでRGBアトリビュートが必要な場合は、CM1、CM2 および CM3 を反転させて利用してください。

旧RGBアトリビュートは、colordim1 (red)、colordim2 (green)、colordim3 (blue)、colordim4 (amber)、colordim5 (white) という名前になります。

既知の不具合および制限:

- grandMA2による MA 2Port Node のリモート設定は、ノードのディスプレイには正しく表示されますが、実際の出力が変更されません。ノードのリセット(電源再投入)後に反映されます。

Version 1.7.0 2010-02-19 リリース

+ MA NPU に MA NSP (Network Signal Processor) 互換モードができました。

+ 新しい Help ビュー。

+ Select Timecode を実装。タイムコード・ビューアは現在選択中のタイムコードにしたがいます。

+ タイムラインを、固定または(入力中タイムコードによる)フォロー・モードにできます。

+ タイムラインのグラフィック・ビュー内で、左右にスクロールさせるためのワイプ・ジェスチャーに対応しました。

+ Help ボタンに続けてキーワードボタンを押すことによって、状況依存ヘルプを表示。コマンドラインでのヘルプ: 例: "help assign please" で Help ポップアップが開きます。グラフィックでない以前のコマンドライン・ヘルプは、"/cmd" パラメータを用いることによって呼び出せます(例: "help m* /cmd" m で始まるすべてのコマンドを表示)。

+ Help ビューでの言語切り替え。

+ Channel および Fixture シートに、新しいフィルタ "Active Only" を追加。

+ Fixture および Channel シートに、新しいシンボル "output selection"。

+ フィクスチャ・アトリビュートが、エンコーダバーのエンコーダにオーバーレイするようになりました。

+ キューのLinkやコマンドラインにおいて、コマンド間に ";" を入れることにより、複数のコマンドを使用できるようになりました。

+ Store エンコーダ・バーに新しい "store only" ボタン。

+ Patch & Fixture Schedule から抜ける際の保存確認ダイアログ。

+ 特殊マスターに "sound in" および "sound out"(内蔵スピーカ用)。

+ "choose store method" ダイアログでのナビゲートに >prev< および >next< キーが使えるようになりました。

+ コマンドラインによるMIDIノートの送出を実装。 例: "MN 5 on/off"

+ 新しい NVidia ドライバ。

+ Store View ポップアップに新しいラベル・ダイアログ。

+ アトリビュート・エンコーダの電卓に "Default Value" ボタンを追加。

+ フィクスチャ・ライブラリを更新。

+ grandMA2 onPC にMIDIインターフェースを実装。

+ MSC(Midi Show Control)出力が動作するようになりました。入力はまだ実装されていません。

+ Content シート: プリセット以外の保存値を電卓で変更できるようにしました(右クリック)。

+ Smart ビューで個々のチャンネルに対する新しい値の保存。

+ タッチフェーダにフォーカスがある場合、モニタ画面2のエンコーダを、Preset/Exec. タイムフェーダに設定できるようになりました。

+ テキスト欄で、Ctrl+C (コピー) および Ctrl+V (貼り付け)が使えるようになります。 例: キューの info

* スナップ機能を持つアトリビュートが、キューのディレイタイムに対応するようになりました。

* エンコーダを押すことで編集画面の開閉ができるようになりました。

* "Please" で編集を閉じた場合、次の行へ移るようにしました。

* Playback ビューの Select Page でクラッシュする不具合を修正。

* 日時に "1" が含まれていると、アジェンダが誤動作する不具合を修正。

* ネットワークにおけるハイライトの動作を改善。

* エンコーダバーの空のエリアにフォーカスを移した後、モニタ画面2エンコーダが100mmフェーダを制御できなくなっていました。

* エクゼキュータのコピーで、チェイサーの割り当てが失われないようになりました。

* 値がプログラマにある場合、Smart ビューの赤ポイントが戻るようにしました。

* color および colormix の混合プリセットが、正しいサムネイルで表示されるようになりました。

* ArtNet が互換モードで動作するようになりました。

* モジュールが認識されない場合でも、"Updatefirmware" コマンドは、強制的にファームウェアをアップデートするようになりました。

* Flash エクゼキュータ・ボタンが、エクゼキュータ・ラベルで青色バーを失わないようにしました。

* 詳細ビューにおいても色見本からカラーを選択できるようになりました。

* Fixture Type グリッドでの作業性を改善。空(または反転)の場合、LongName は FixtureType:ShortName に設定します。Manufacturer <-> ShortManuと同様。

* "On fixture x" で更新機能が有効になります。また "Fixture x at Fixture y" でも同様です。

* チャンネルページで Flash ボタンが機能するようになりました。 注:値はプログラマへは行きません。

* 最初に押したときに、Kill機能が働きませんでした。

* Playback ビューで空のエクゼキュータ・ボタンに新しいシーケンスを保存できるようになりました。

* Fixture および Channel シート: "Effects Editor" で "Show Selection" が選択されている場合、"Prog. only" や "Fixture sort" が動作します。

* Tracking および Content シートで、"Effect ID" レイヤが、保存されているエフェクトを表示するようになりました。

* Content シートのフィクスチャが、フィクスチャIDで保存されるようになりました。

* Tracking シートの "Name" 列の幅がビューに保存されるようになりました。

* Edit Setup に新しい "Fixture Wizard"。

* Update ビュー: タッチ画面で空のエリアに移ることによって、すでに選択されているキュー、エフェクト、プリセット行の更新を中断できるようにしました。

* パーク・マスクのある Fixture シートにおいて、Clear all でパークされているアトリビュートがクリアされませんでした。

* Fixture および Channel シート: "Effects Editor" で "Show Selection" が実行された場合、"Prog. only" や "Fixture sort" が動作するようになりました。

* マルチユーザ・アトリビュートのアクティブ化によって、すべてのユーザに対するセレクションが壊されることがないようにしました。

* Ctrl と Shift ボタンが、卓のマウスとともに動作するようになりました。

* Tracking シートにおいて、電卓による値の変更が正しく表示されるようになりました。

* ロングネームを持つ Label ビューページが、キャリッジリターンで表示されます。

* サウンド入力ビューのリサイズが正しく動作するようになりました。

* Edit Setup でフィクスチャタイプを変更した際に、新しいフィクスチャタイプが古いものより多くのパラメータを持つようになると、DMXパッチが削除されます。そうでない場合、パッチはそのままです。

フィクスチャを編集してアトリビュートを追加すると、誤パッチの原因となります。パッチをやり直す必要があります。

* キューにプリセットが保存された際の Update Cue や Store Cue Merge も同様に動作します。

* 卓のDMX In のデフォルトを OFF に変更。

既知の不具合および制限:

- grandMA2による MA 2Port Node のリモート設定は、ノードのディスプレイには正しく表示されますが、実際の出力が変更されません。ノードのリセット(電源再投入)後に反映されます。

- ショーを開始し MA NPU がセッション内にある場合、アクティブなシーケンスからの卓出力はありません。

- DMX入力が卓や MA NPU に初めて接続されてから卓の電源を入れた場合、卓のDMX入力が動作しません。

Version 1.6.0.3 2009-12-22 リリース

* Content シートや Track シートでスクロールした際にクラッシュする不具合を修正。

* タイムコード・ビューを削除した際にクラッシュする不具合を修正。

* フィクスチャが置換された場合のパッチの解除。

Version 1.6 2009-12-18 リリース

+ タイムコードが実装されました。grandMA シリーズ1での操作理念に対して以下を追加。新しいタイムコード・ビューは、すべての画面に自由に配置できます。タイムコード・プールで、タイムコードの状態を見ることができます。入力タイムが現在の記録範囲内にある場合、タイムは緑表示になります。内部TCショーに対するリピート機能。新しいコマンドライン・キーワード "record"。ユーザビットは、入力タイムコード信号を識別できます。

+ Backup メニュー: 現フォルダ内にある旧バージョンの全ショーファイルの自動コピーをやめました。バージョンごとにフォルダが作られます。これは、そこから古いショーファイルを読み込むことができ、そして現バージョンのフォルダに保存されることを意味しています。旧バージョンのショーファイルはそのまま残ります。

+ アトリビュートおよびエンコーダのグルーピングが実装されました(Setup/ Show/ Patch & Fixture Schedule/ Fixture Types)。 注1: 他のプリセットタイプにアトリビュートを移動させた後、プリセットタイプを削除できるようになりました。残りのプリセットタイプは、自動的にリナンバーされます。マクロからプリセットタイプを呼び出す場合は、IDではなくプリセットタイプ名を使用してください。 注2: このバージョンでは、エンコーダのグルーピングは、番号によってのみ動作します。プログラマ内でアトリビュートをアクティブにすると、それと同じ番号を持つすべてのアトリビュートもアクティブになります。

+ Assign メニューの Restart オプションに、First Step、Current Step、Next Stepを追加。

+ チャンネルページは、最初の方法で動作します。自身のフィクスチャをチャンネルページに割り当てることができます。空のページを作成するには、チャンネルページに切り替えます。>assign channel 1 thru< とし、最初のチャンネル・フェーダを押すと、すべてのチャンネルが割り当てられます(grandMA シリーズ1と同様)。>Assign channel x channelfader y< とすると、このチャンネルが現在のチャンネルページに割り当てられます(channelfader に対するショートカットは cf)。>Assign channel x channelpage y.z< (channelpage に対するショートカットは cp) 注: Flash ボタンは、プログラマでは動作しません。

+ Setup/ User/ Settings: メッセージボックスがすべてのモニタ画面に表示されます。

+ Setup/ User/ Settings: "Wheel Mode" がモニタ画面2にも表示されます。

+ プリセット・タイムフェーダとエクゼキュータボタン・タイムフェーダに対する新しい "Set Time" ボタンを画面2に追加。また、エクゼキュータへの特殊マスターに対して、On および Off ボタンを割り当てることもできます。

+ Solo が、選択されているユーザ・ワールドで動作するようになりました。

+ 単独フィクスチャの単独アトリビュートに対してプロファイルを割り当てられるようになりました(>Edit Fixture x<)。

+ Setup でのパッチで、現在パッチされているDMXチャンネルを概観する新しいビューが開きます。

+ フィクスチャタイプのインポート・エクスポート。

+ USBへの、およびUSBからのマクロ。

* Store Options で "If not Empty" の "Merge" が有効の場合、新しいプリセットとグループを保存できるようになりました。キュー1、3、5を含むだけの現キュー・リスト上でコマンド >store 1 thru 6 merge< が実行されても、新しいキューを作りません。

* ATTN: MIDIノートが送受信する番号付けが一致するようになりました(古い設定では +-1)。

* Setup/ リモート入力/ MIDIリモート: MIDIチャンネルを0に設定すると、1つのノートからの「すべて」のチャンネルの意味になります。

* Specialized Shaper ダイアログ: U1〜U3ボタンの機能がソフトボタンと同じになりました。

* チャンネル y からの値が選択プリセットから来ている場合、>channel x at channel y< が正しい値を表示するようになりました。

* ノントラッキング・シーケンスにおいて Split X Fade が正しく動作するようになりました。

* Tracking シート: 定義済みセット(1〜5)を編集する際に、対応するウィンドウが開きます。

* Fixture シート: 列の順番が、偶発的に変わることがないようになりました。

* アジェンダ: Week ビューを改善。

* アジェンダ: スレーブ卓でも項目を作成できるようになりました。

* ブレークを持つフィクスチャのパッチがコマンドラインからできるようになりました。>assign Fixture 1 true 10 at DMX 2.1/break=1<

* プリセットを走らせたり、あるいは、プリセット・プールでアクティブなフォーカスを持つビューボタンを呼び出したりしても、エンコーダバーは切り替わりません。プールのタイトルをフォーカスしたり、コマンドラインからプリセットタイプ名を呼び出したりした場合にのみ、バーが切り替わります。

* ショーのアップロード後にネットワークでの短いフェードタイムが、すべてのネットワーク・プロトコルで動作するようになりました。

* コマンド "Terminate effects" がプログラマで動作するようになりました。

* grandMA2 onPC がウィンドウ・フレームで動作している場合、ウィンドウのタイトルバーをつかむことによってのみ移動可能です。ウィンドウ・フレームが無い場合は、背景を叩くことによってのみ移動できます。

* タイムなしのフォロー・キューでは、MA NPU を持つネットワークにおいてセーバーが動作します。

* スレーブ卓からコマンドラインでDMXアドレスを削除すると、出力のDMX値も削除されます。

* Sequence シート: 列を移動した後、内容をエンコーダで変更できます。

* キューを更新すると、元の内容のみが再び動作します。

* ユーザプロファイルのコピーが、ネットワークで正しく動作するようになりました。

* Active for Selected をともなう Store や Remove が動作するようになりました。

* チェイサー・エンコーダバー: リバース・ボタンが動作するようになりました。

* 再起動後、ユーザログインが同じままになるようにしました。

* フィクスチャやチャンネルがセレクトされていると、エンコーダ・プレイバーはなしになります。

Version 1.5.0.3 2009-10-30 リリース

* ビューを閉じた際に卓がクラッシュする不具合を修正。

* キュー内のプリセット値が Update によって解除されませんでした。

* プログラマ変更後に、いつも Smart ウィンドウがフォーカスを奪っていました。

* Sheets Feature Sort が動作するようになりました。

* 表パネルにおける脱落が無くなりました。

+ Setup/ Show/ Patch & Fixture Schedule に、フィクスチャタイプに対して便利な新しいプロファイル・エディタ。

+ Fixture、Channel、Content および Tracking シートに、新しいカラー表示とオプション。カラー・バー(マーカ):シートのオプションでマーカを無効にできます。Fixture および Channel シートのタイトルバーに、"Programmer only" ボタン。

  • 赤 = プログラマ内のアクティブな値
  • 白 = プログラマ内の非アクティブな値
  • 緑 = プログラマ内のフェード値
  • オレンジ = プログラマ内のディレイ値
  • シアン = プリセットからの値
  • マゼンタ = エフェクトからの値
  • 青 = パークしている値
  • 灰 = プロファイルが割り当てられている

+ Chaser Edit メニューが実装されました(Sound/ BPM によるトリガーはまだ使えません)。

+ Edit Cue Number メニューが実装されました(Sequence Executor シートの "Number" 欄で右マウスクリック)。キューのリナンバーも可能です。

+ 現在のフォーカスがビューに保存されるようになりました。

+ 新機能:マスターフェーダが50%のエクゼキュータで "dimmer value full" を更新すると、200%のディマー値が保存されます。

+ ユニバーサル・エフェクト。(ユニバーサル・プリセットと同様に)エフェクトは、それを構成しているすべてのタイプのアトリビュートで使うことができます。プログラマのタイミングは今のところ使用できません。

+ Off エフェクトが、プログラマで動作するようになりました。

+ 新キーワード:"SyncEffects" (>MA< + >effect< を押す) で、プログラマ内のエフェクトが同期します。

+ グランドマスターと100mmフェーダが、Ultralightにおいてモータ駆動動作するようになりました。

+ Backup/ Load Show で仮想キーボードが使えるようになりました。

+ At フィルタが、ワールドフィルタとともに動作するようになり、また Zoom ボタンが付きました。

+ Strand Genius Plus からの ASCII インポート: プロファイルが実装されました。

+ Edit ビュー(エクゼキュータの上の小さなエクゼキュータ・ウィンドウを押すと開く)が、モニタ画面1または2に表示できます。

+ >Ifoutput at time 1 thru 5< は、1〜5秒の個別タイムを持つすべてのフィクスチャをセレクトします。

* フェーダウィングのモータ駆動フェーダが、Ultralight とともに動作するようになりました。16〜30のフェーダ位置にウィングを割り当てるために、"alignf" コマンドを使ってください。

* ETC Net2: CCL は、パッチやパーク変更の後で更新されます。

* Smart ビューが、アクティブでないプログラマ値を誤って表示しないようにしました。

* 複数の問い合わせテキストを持つマクロが動作するようになりました。

* >fixture x at cue y sequence z< に対して At フィルタが動作するようになりました。

* >Ifoutput< は、0以上のディマー値のみをセレクトするようにしました(grandMA シリーズ1と同様)。

* シートのサイズ変更で、タイトル行のボタンが壊れないようになりました。

* >Save as< は、セッション内のすべての卓上で、ショーの新しい名前を用います。

* デフォルト・ハードキー GO/ GoBack/ Pause: 機能が CommandLine Feedback ウィンドウに表示されるようになりました。

* >Clear< は、選択中のワールドのみをクリアするようにしました。隠れているワールドはクリアしません。

* TEMP および FLASH ボタンが、エクゼキュータ・ボタンで正しく動作するようになりました。

* 定義済みマクロ・ライブラリが改訂されました。

* 無効なコマンド >fixture thru at world x< で卓がする不具合を修正。

~ タイムコードの編集およびビューはまだ動作しません。

+ 新しいプロファイル・エディタ。

+ プロファイルが、Channel/Fixture シートに白いバーで表示されるようになりました。

+ 複数のプール/シートを画面にビューとして保存した場合、現在のフォーカスも保存されるようにしました。

* Sequence シートにおける表示の不具合。

* Smart ビューが、アクティブでないプログラマ値を誤って表示していました。

* 複数の問い合わせテキストを持つマクロが動作しませんでした。

* >fixture x at cue y sequence z< でフィルタが動作しませんでした。

* >If at time 1 thru 5< は、1〜5秒の個別タイムを持つすべてのフィクスチャをセレクトします。

* Setup でレイヤに多数のフィクスチャがある場合、一覧の末尾からフィクスチャを削除すると、フォーカスが先頭に移ります。

* シートのサイズ変更でボタンが壊れていました。


Strand Genius Plus からのASCIIインポート

設定: プロファイルのインポートは実装されていません。Parameter Limits EXPERIMENTAL のASCII インポートについて、このフィーチャに依存する DLC のようなフィクスチャでは、スクローラが終端で破損しないように注意してください。

キュー: キュー・リストは、ブロックが完全に解除され、トラッキング・シーケンスとしてインポートされます。編集を始める前に、Strand ショーファイルを見て、ブロックを再設定したいと思うかもしれません。

サブマスター: エクゼキュータ・フェーダの優先度が正しいか確かめてください。禁止されているサブマスターが、MA2上でネガティブ・グループ・マスターであり、またそれに応じてインポートされていることにも注意してください。

エフェクト: インポートしたエフェクト・シーケンスをチェイサーに変換(また、キュー・トリガーを 'Go' に変更)したい、あるいは、それらを MA2 エフェクトとして書き直したいと思うことがあるでしょう。Strand エフェクトを、インポートしたままに保持したい場合、残念ながら、実際に用いる前に変更を行う必要があります。Effect Off オプションは、ASCII ファイルにはエクスポートされませんので、ショー全体を調べて、すべてのエフェクト・シーケンスがオフ・トリガーを持つことを確かめる必要があります。それには、いくつかの案があります。

キュー・リストにおける Effects Off コマンド: Strand キュー・リストで小文字の 'f' があるところを調べて、シーケンスを停止するために 対応する MA2 Cmd Link を変更してください。

Cycles 後の Effects Off: 最後のキューから最初への [Wrap Around] Loop を無効にし、希望するループ回数を追加して、最後に新たな空のキューを作成してください。ループが完了したときにそれが望んだように動作するように Trigger タイプ を設定しまたシーケンス停止のために関連する Cmd Link を割り当ててください。

Time 後の Effects Off: シーケンスの先頭に、空キュー 0.001 を作成してください。必要なタイムに Cmd Delay を割り当て、またシーケンス停止を知らせるために Cmd 欄を入力してください。このキューが最初の実行後に再トリガーされることがないように、残りのキューに Loop 機能を用いてください。

Version 1.4.1 2009-09-30 リリース

+ 新しい MA 2Port Node Version 1.36 で、多数のパラメータ値を同時に変更する際の性能が向上しました。

+ シーケンスに対する新しい Assign メニューのオプション

  • Auto Stop を無効にし、Master Go がアクティブだと、フェーダを再び上げたとき、次キューが開始します。
  • Master On: 前述と同様ですが、フェーダを上げた場合、現在のキューが再開されます。
  • Master Go Off: 前述と同様ですが、フェーダを上げた際にディマーだけが変化し、同じキューはその間ずっとアクティブなままです。

+ CMYに対する仮想ディマー機能が実装されました。

+ Fixture シートにおける新しい設定 Readout "Natural" は、フィクスチャタイプ自身のための範囲設定を反映します。これは、Setup でフィクスチャを編集し、また制御エンコーダの単位を変えるために Fixture シートでの設定を変更することによって、フィクスチャ制御のための範囲を自分で定義できるということです。

+ 新規ショーを開始したり、既存のショー名と同じショーを保存したりした場合、ユーザ・プロンプトが警告します。

+ モニタ画面1や2の画面エンコーダに対するエンコーダ選択ボタンが理にかなったものとなり、その状態が、画面上のフォーカス変更に切り替わるようになりました。

+ Setup/Network/MA Network Control では卓の一覧表示だけにしました。他のすべてのステーションについては、Setup/Network/MA Network Configuration で設定、招待、解除できます。

+ grandMA2 でフィクスチャタイプのライブラリを改善。

+ コマンドラインによってマルチパッチを適用できるようになりました。 例: Assign Channel 1 at DMX 1.1 thru 1.50 は、チャンネル1の現在のパッチを上書きします。Assign DMX 1.60 at Channel 1 は、マルチパッチを追加します。またDMXユニバースで絶対アドレス指定が可能になりました。 例: Assign Channel 1 DMX 513 thru 1025

+ grandMA2 replay unit (RPU) にスクリーンセーバーのオプションが付きました。

+ MA ボタンと "."(ドット)ボタンで、プログラマ内でセレクトされているフィクスチャに対しデフォルト値がコピーされます。

* Copy Cue X at Cue Y は、Sequence Executor シートで入力されたすべての値をコピーするようにしました。

* 電卓で "basic" オプションを適用すると、キューのタイミングが適用される代わりに、プログラマから個別のタイミングが得られるようになりました。

* 卓の設定、ローカルにエクスポートされたマクロ、ローカルに保存されたビットマップおよびフィクスチャファイルが、新しいリリースがインストールされた際にコピーされるようになりました。

* Fixture X at Fixture Y は、grandMA シリーズ1でのように、デフォルトではない値のみをコピーし、また同時に At Filter を用います。

* プリセット・タイム・フェーダが秒で調整できるようになりました。

* シートの列幅を調整してビューに保存した場合、ビューを再び開いたときにその設定が呼び出されるようになりました。

* Fixture および Channel シートで、Multi Control オプションが再び動作するようになりました。

* フィクスチャまたはチャンネルが解除された場合、Channel および Fixture シートに (R) と表示されます。

* マクロにおけるテキスト入力(例: Group("Which Group do you want to select?"で、ユーザプロンプトに疑問符を書けるようにしました。

* Off All ボタン、Off All フェーダ、そして Off メニューの Everything Off が、すべてのエクゼキュータページに適用されるようになりました。

* チャンネルやフィクスチャのディマー値を100%以下でアクティブにした場合、100%に跳ね上がらずに、値がアクティブ化するだけになりました。

* Smart ビューが自動的に更新されるようになりました。

* 同一のパラメータを持たないフィクスチャ(例えば、Pan/Tiltを持つものと持たないもの)を制御している場合、電卓によって値を再度入力できるようになりました。

* Fixture シートによってアトリビュート・エンコーダの上の画面で用いられる単位を選択できます。複数の Fixture シートを使用している場合、最後に選択されたものがそれらを制御します。

* Setup/User/Defaults/Sequence Defaults において Snap Delay Defaults が動作するようになりました。

* Fixture シートがセレクトを行うためにスクロールしている場合、ユーザが別のワールドをセレクトしても、この状態を保つようにしました。

* エクゼキュータのプログレスバーは、タイミングをともなった Goto や Off コマンドも考慮するようにしました(例: Goto Cue 5 Fade 4)。

* At Filter が、At Cue、At Preset および At Effect との組み合わせで用いた際にも動作するようになりました。

* フィクスチャタイプを編集する際の Beam 明度 で、180以上の値を取ることができるようになりました(3D ビジュアライザ用)。

* エクゼキュータの編集ウィンドウを開いてキュー1を削除すると卓がクラッシュする不具合を修正。

* セッションのマスターが切断しても、自動的にセッション内の他のマスター・ステーションを選ぶことによって、セッションを生かしたままにします。

* 2台の卓が接続されていて、スレーブ卓が Setup に入ってから抜けた場合でも、Art-Net値の中断はありません。

* グランドマスターへのチャンネルやフィクスチャの関連付けを断った場合でも、Art-Net値の中断はありません。

* パークされている値は、スレーブ卓に接続されてるマスター卓の Setup を抜けても、保たれるようになりました。

* Relative Effects で負の値範囲も可能になりました。

* キューの範囲をコピーできるようになりました(例: Copy Cue 2 thru 4 at Cue 9)。

* Edit Exec X と Delete Cue Y で卓がクラッシュする不具合を修正。

* Edit Cue X は、キューに現在保存されている値だけでなく、トラッキング情報も含めて、キューの状態をプログラマにもたらします。

* パート・キューが保存されると、ユーザ・プロンプトは、パートがすでに存在するかが表示されるだけになりました。

Version 1.4.0.2 2009-09-11 リリース

grandMA2 のエフェクト導入にあたっての全般的な説明

新しいエフェクトについて考えるにあたって、すでに知っている一般的なプリセットとよく比較してみましょう。

エフェクトは2種類のデータ・セットを含んでいます。

  • 最初のセットには、一般的なルールが含まれます。
  • 2番目のセットには、チャンネルごとに一般ルールを個別に上書きしたものが含まれます。

この動作を、キューにおける基本/個別タイミングと比較したくなるかもしれません。そこで、一般ルールに由来するエフェクト・パラメータを基本(Basic)と、その他のパラメータを個別(Individual)とよぶことにします。

以下のようにして新規エフェクトを作成した場合、完全な基本エフェクトとなります。

  • 空のエフェクトを編集
  • 1つまたは複数のエフェクト行を追加
  • エフェクト行にアトリビュートを割り当て
  • エフェクト行に対して現在のセレクションを割り当て
  • パラメータによって再生

新たにエフェクトを動作させるには3つの方法があります。

  • プリセットのように、プログラマに呼び出す
  • エクゼキュータに直接割り当てる
  • プリセットと同様に呼び出した後、キューに保存
新規エフェクトは基本パラメータのみを含むため、動作中のエフェクト・パラメータは、Fixture シートにおいて灰色で表示されます。

しかし、エンコーダをエフェクト・パラメータに切り替えて回すと、プログラマ内での個別オーバーライドが有効になり、Update のLEDが点灯します。

元のエフェクト・パラメータに応じて、Update ポップアップには、エフェクトの更新か、または代わりにキューを更新するのかの選択肢が示されます。

エフェクトを更新すると、個別の変更がエフェクトに保存され、このエフェクトを基本として使用していたすべてのキューも、次の実行時から新たなエフェクト・パラメータを示すでしょう。

一方キューを更新した場合は、個別の変更はそのキューにのみ適用され、同じエフェクトを基本として使用している他のキューには影響しません。

更新後、エフェクト/キューを再び動作させてみてください。個別エフェクト・パラメータは、Fixture シートで明確に黄色で表示されます。

エフェクトを更新し、Effect Editor を見れば、2種類のものがあるのに気付くでしょう。

  • エフェクトは、個別パラメータを分析することによって、一般ルールを変更します。また、一般ルールに従うパラメータの大部分はもはや個別ではないとすることにより、エフェクトは最適化されます。
  • 個別パラメータを持つエフェクト行は、赤っぽい背景色で表示されます。

他に以下の点で、grandMA シリーズ1 のエフェクトとは異なっています。

エフェクトの出力値は、別に計算され、エフェクト行のパラメータである Value1 と Value2 の間の値となります。Value1 と VALUE2 の間の推移は、選ばれた Form によってコントロールされます。プリセットを Value1 または Value2 として用いることも可能です。

~ プログラマは、エフェクトをフェードさせることはできません。

+ AsciiShowRead

すべてのファイルをUSBソースから込み込みます。

このときサポートされているは Manufacturer 'Strand' Console 'GENIUSPLUS' です。

異なるソースを用いようとすると、警告が出ます。

Backup → USB → AsciiShowRead とアクセスします。

Read All: 空のショーで Setup + Data を作成。
Read Setup: 空のショーで Setup のみを作成(設定を確認し変更できるでしょう)。
Read Data: Data のみを作成(適合する Setup があるときのみ)。
Group x below 900 Preset All x になります。
Sub x Exec x に割り当てられます。
Sub x Inhibit Exec x Group x に割り当てられます。
Cuelist DefaultExec として Exec 201 に割り当てられます。
Effect x Exec 100+x に割り当てられます。Mode $$Bounce に対応しました。

その他:

+ Move 機能が実装されました。

+ 既存のファイル名にショーを保存したり、ショーを開始し既存のものと同じファイル名を付けようとしたりした場合、上書きするかキャンセルするかのプロンプトを出すようにしました。コマンドラインに "newshow anyshow /noconfirm" と入力すると、名前が既存のものであっても、プロンプトを出さずにそのまま新規ショーが作成されます。

+ Copy Cue が実装されました。

* MA NPU がフィクスチャや値に対する Unpark コマンドを認識せず、新しい値があるまでパーク値を出力していました。

* "Off" ハードキーとアトリビュート・エンコーダの1つの押し下げによってプログラマ内の値が非アクティブになっても、コマンドラインでは "off" のままでした。

* "Assign Cue X Time Y" で、すべてのキューおよびパート・キューにタイムyを割り当てていました。

* "Patch&Fixture Schedule" でのパッチ変更によって、"Patch&Fixture Schedule" を抜ける際に、DMX値がゼロに設定されていました。

* "Edit Bitmap X" 中に Modulator シートに入ると卓がクラッシュする不具合を修正。

* フィクスチャ名を設定する際の自動連番付け(例: Mac 1)が動作してませんでした。

* Copy Page x at Page y で卓がクラッシュする不具合を修正。

* Setup のコマンドライン・ビューにおけるフィクスチャタイプの識別が実装されました。

* 16ビット分解能のユーザフィクスチャファイルで、両DMXチャンネルではなくファイン・チャンネルのみしか送信されていませんでした。

* シーケンスに対して Executor シートを開き、"Edit Sequence" を行ったとき、"A"(Assert) または "MIB" エンコーダを回すと卓がクラッシュする不具合を修正。

* Fixture シートに保存されたビューが、Page Down/ Page Up の選択に一致していませんでした(Fixture Sort は Off)

* エクゼキュータにボタン機能として割り当てられた Toggle が、タイミングに反映するようになりました。

* シーケンスにキューの欠番がある場合、"Store Cue Thru" で "remove" オプションを選ぶと、新規キューが挿入されます。

* "Copy Preset x at Preset y" で "merge" を選ぶと2つのプリセットをマージできるようになりました。

* Smart ビューが Attribute エンコーダとリンクするようになりました。

* Preset/ Layer/ Filter Control に対する Fixture シートのオプションを再び修正。

* 開いている At Filter メニューでスクロールすると、フィルタにおけるすべてのセレクションが削除されていました。

* GUI とコマンドラインから Setup に入り再び Setup から抜けると卓がクラッシュする不具合を修正。

* GUI の Setup にユーザがいると、Telnet によって Setup に入ることができませんでした。

* Store Preset X、label Preset X "33%"、label Preset X "33% new" で卓がクラッシュする不具合を修正。

〜 チャンネル機能の Attribute 欄は編集可能です。

〜 Move Cue は開発中です。

Version 1.3.0.1 2009-08-25 リリース

* "Patch&Fixture Schedule" でパッチ変更した際、"Patch&Fixture Schedule" を抜けるときにDMX値がゼロに設定されていました。

Version 1.3 2009-08-13 リリース

+MA 4Port Nodes に対応しました。MA NSP のハードウェア・インターフェースでモードが手動変更された場合は、grandMA2 卓からのみ設定が可能です。MA NSP は、grandMA シリーズ1から更新されたバージョン6.123以降で動作していなければなりません。

+ バージョン1.35の新しい MA 2Port Node では、grandMA2卓からの設定が可能です。

+ エフェクト・エンジン用の新しいユーザ・インターフェースを実装し始めました。これはまだ完了していなく、エフェクト操作は今のところまだ改善されていません。

+ Goto Cue x Time y と Store Cue x Time y が実装されました(Store Time y では、短い構文で、次キューをフェードタイムとともに保存できます)。

+ Assign Time Time Time x Cue y で Delaytime x を キュー y に割り当てられます。

+ Store や Assign を押してから Time ボタンを数回押すことによって、"Basic Fade"、"Basic Out Fade"、"Basic Delay"、"Basic Out Delay"、"Snap Percent"、"Command Delay" が可能になりました。

+ 現在のワールドの部分ではない場合、グループ・プール内のグループに赤いバーが表示されるようにしました。

+ エクゼキュータが Off タイミングに対応しました。Off マスターには、0〜10秒の値を設定できます。

+ エクゼキュータの Assign メニューのオプション設定も、ユーザプロファイルに保存されるようにしました。これは、エクゼキュータ・デフォルト、チェイサー・デフォルト、エフェクト・デフォルト、ビットマップ・エフェクト、グループ・マスター、特殊マスターも含みます。

+ Macro メニューで定義済みのマクロを挿入できるようにしました。これは grandMA での Quikeys に似ています。

+ Assign メニュー、Edit Macro および Edit Effect メニューを、モニタ画面1または2に置けます。

+ Backup メニューを改訂。新規ショーの作成、および開始する際の設定を定義できます。

+ Setup/ User/ Grandmaster B.O. etc. において、Grandmaster、Blackout、Solo、Highlite をユーザごとに無効にできるようにしました。

+ Edit Channel x、Fixture x で、モニタ画面1に編集ダイアログが開きます。

+ MA Network Configuration に新機能 Add Present、Remove Absent、Remove Non-Members を追加。

+ MA Network Configuration に新機能を追加。現セッションのすべてのメンバーを緑色で表示し、招待や解除が可能です。

+ エクゼキュータの優先度を表示するようにしました。< = Low、L = LTP、> = High、H = HTP、S = SWAP

+ ワールド・プールに、アトリビュート・フィルタ表示を含めました。

+ リモートDMX入力に "Programmer" を追加。DMX入力からの変化値が、プログラマにそのまま挿入されます。

+ ユーザプロファイルが、ショーファイルだけでなく卓にも保存されるようになりました。これは、新しいショーを読み込んでも現在のプロファイルが保持されることを意味します。

+ ショー保存のコマンドを実行すると、マスター卓およびセッション内のすべての卓に保存されます。

+ Backup/ Load Show で、ショーファイルから読み込む項目を選択できるようにしました。

+ コマンドとしての "Edit Group" は、更新機能をともないます。

+ Copy Executor x <Page Up> at Executor y で、ページをまたいだエクゼキュータのコピーが可能になりました。また "Edit Preset" や "Edit Group" で、プールボタンにラベルを付けられます。

+ リモート設定において、キーコードを選択するための新しいポップアップを追加しました。

+ すべてのシートにおいて、ユーザが作業しているワールドを表示するようにしました。

* Specialized Color または Shaper ダイアログで作成されたプリセットを保存した際、フォーカスはプリセットに移り、すぐにラベル入力ができるようにしました。

* VL3500 のシェイパーの物理値を修正しました。

* Copy ViewButton x At ViewButton y が動作するようになりました。

* Tracking シートでのフィクスチャソートが正しく動作するようになりました。

* Tracking シートに、Load Cue も表示されるようになりました。

* 選択、固定、またはその両方の状態にあるエクゼキュータを表示できるようにしました。

* 電卓によるフェードタイムの編集時に、Edit Sequence ウィンドウ上の複数のキューを一括設定できるようにしました。

* ワールド・プールで、選択されているワールドに対する表示がなされるようになりました。

* ゴボ・ライブラリを改訂しました。

* フィクスチャタイプ・ライブラリを改訂しました(特に、デフォルト値、ハイライト値、ゴボホイール)。

* グループ・プールでグループを編集すると、編集メニューが開き、またそのグループに "Edit" というマークが付くようにしました。

* Delete または Edit Group x が、Full ワールドではないときに動作しませんでした。

* Fixture シートの水平方向の列順序も、ビューに保存できるようにしました。

* Telnet接続で卓の設定を行っている際に、設定から抜けなくてもTelnetセッションを閉じられるようになりました。

Version 1.2 2009-07-20 リリース

+ MA 2Port Node は grandMA2 に対応しています。MA 2Port Node をアップデートするには、従来どおり grandMA か grandMA onPC 6.122 を使用してください。このバージョンでは grandMA2 からのアップデートはできません。バージョン1.32以前のノードは grandMA2 に対応していないため、他に方法はありません。将来、MA 2Port Node がバージョン1.34になれば、この手続きが機能するでしょう。

+ 2Port は、grandMA での MA NSP のように扱え、Setup において手動で挿入できます。Add をクリックすると、利用可能なすべてのユニットの一覧を見ることができます。将来は、コマンドラインでの "NNU"(Network Node Update) や、"Software Update" 画面ボタンによって、卓からノードのアップデートができるようになるでしょう。

+ コマンドラインで "NNI" (Network Node Info)と入力すると、ネットワーク内で利用可能なすべての MA 2Port Node についての情報が一覧表示されます。

+ Desk Lock を解除すると、100mm メイン・エクゼキュータおよびグランドマスターは、最後の位置に復帰します。

+ 卓とネットワーク上デバイスのDMXポート設定のためのグラフィック・インターフェース。

+ Sequence Executor シートに5つのセットボタンを追加。

+ 100mmのメイン・エクゼキュータに Special Master 機能を追加。

+ Channel や Fixture シートのレイヤ・コントロールバーは、自動モードの場合、フェードおよびディレイ値を反映します。

+ Sequence Content シートに Assert オプションを追加。このオプションは再生時に働きます。値がトラッキングされていて、最初のシーケンスでブロックされていなくて、エクゼキュータ上の他のシーケンスによって上書きされた場合、最初のシーケンスに対して Assert を有効にしていると、他のエクゼキュータが動作していても、最初のシーケンスのトラッキングされた値が出力されます。

+ プログラマに対する Preset Time Fader は、ネットワーク全体に渡って、ユーザごとに独立しています。

+ キュー編集の際の Update ダイアログを実装。

+ Setup、Patch、Fixture Schedule に新しいウィザードを追加。

+ Sequence シートにおけるインおよびアウトフェード、ディレイタイムの表示を新しくしました。

+ ショーのアップロードを、圧縮して時間を短縮しました。

+ 自動保存が実装されました。

+ コマンドラインを grandMA2 replay unit (RPU) / MA network processing unit (NPU) で用いるための、画面キーボードを実装。

+ Sequence Executor シートにも、Load Cue が表示されます。

+ "Set to default" がボタン割当用に動作するようになりました。

* Stage View を開く際に、フィクスチャのダミー・パラメータで卓がクラッシュする不具合を修正。

* Smart ウィンドウでのスクロールが可能になりました。

* Smart ウィンドウでのグラフィック表示を修正。

* モータ駆動ではないフェーダがつかめるようになり、正しい位置にないフェーダの赤LEDが点滅するようにしました。

* Delete ハードキーを押し、Sequence Executor シートで番号の1つをクリックすると卓がクラッシュする不具合を修正。

* Sequence Executor シートにおいて、ディレイおよびフェードタイムが、遷移終了後に正しく表示されるようになりました。

* Assign Flash Executor Function Button 1 が常に Button 3 に働いていました。

* Assign メニューの "priority normal" を "priority LTP" に変更。

* ジッターの低減と、Crazy Shaper ダイアログにおける物理的なフィクスチャの制限の通知を改善。

* 多くの内蔵フィクスチャタイプの物理値を改善(例: パン、チルト、ズーム、シェイパー・ブレード、ビーム角、ゴボ回転…など)

* カラー・ライブラリの色を修正(主に暗色)。

* Fixed Playback View Pages で、エクゼキュータの固定を取り除きました。

* シーケンスの最後から最初のステップに飛んだ際、キューフェードおよびディレイタイムが働いていませんでした。

* パート・キューの Update が可能になりました。

* アップデート終了時に、Update ウィンドウが自動的に閉じるようになりました。

* "Edit Group" で卓がクラッシュする不具合を修正。

* シーケンスが二本のフェーダ・エクゼキュータに渡っていて、かつ2番目のフェーダにスピードが割り当てられていると卓がクラッシュする不具合を修正。

* Pan/Tilt アトリビュートを持たないフィクスチャは、Setup や Edit Fixture ウィンドウで編集できませんでした。

* Streaming ACN を実装し直しました。

* grandMA2 RPU の Power Button が動作するようになりました。

* ScrLck キーの状態が表示されるようになりました。

* Off メニューの Everything Off ボタンが動作するようになりました。

* 異なったストリーミング・バージョンを持っていたり、Station Invitation が "Disabled" のステーションは、MA Net Control ウィンドウで赤表示するようにしました。

* Sequence Executor シートの Info 欄に "thru" を入力すると卓がクラッシュする不具合を修正。

* ブレードを Shaper ダイアログから遠くへドラッグすると、そこからもう動かせなくなっていました。

* Fixture シートにおいて、オプションの Cue Colors が機能していませんでした。

Version 1.1 2009-06-17 リリース

+ 他フィクスチャからのプログラマ値のコピー: Fixture [フィクスチャリスト] At Fixture [フィクスチャリスト]。

+ ArtNet2 が実装されました(ユニバーサル当たり2ノードよりも多くない場合)。

+ AT-Filter ウィンドウ("AT" を長押し)。

+ Off メニューを改善。

+ Scroll Lock キーを有効にすると、どのキーボードを押してもコマンドラインにインタープリトします。

+ Update メニューを改善。

+ ページ名が卓に表示されるようになりました。

+ Network オプションに Invite Station を追加。

+ Network オプションに Auto Invite を追加。

+ Art-Net および Streaming ACN プロトコルの実装を改善。

+ Desk Lock ダイアログを実装。

+ Part Cues に付加情報列を含めるようにしました。

+ シーケンスの編集ウィンドウを閉じると、エンコーダの上のバーも自動的に閉じるようにしました。

+ エンコーダの上のバーを保持するために、Edit ウィンドウに Keep Bar オプションを追加。

+ Fixture シートでのフィクスチャを編集する際に、色見本にアクセスできるようにしました。

+ Channel および Fixture シートで、それらの内部的なカットアウトを保存するようにしました。

* MA NPU の追加・解除を行うと、すべてのDMX値がデフォルトになっていました。

* Setup で複数のレイヤ行を選択するとクラッシュする不具合を修正。

* オプションだけが有効なプログラマの Fixture シートがあるときにワールドを変更するとクラッシュする不具合を修正。

* Setup でレイヤのすべてのフィクスチャをリネームするとクラッシュする不具合を修正。

* エクゼキュータ編集中に何かを削除するとクラッシュする不具合を修正。

* エクゼキュータ編集中にエンコーダ1を押し下げるとクラッシュする不具合を修正。

* Fixture Schedule にいるときにシャットダウンすると卓がクラッシュする不具合を修正。

* Fixture シートで、フォーカスとズームが正しく表示されていませんでした。

* エンコーダがビデオ・プリセットに割り当てられていると、プリセットを保存できませんでした。

* いくつかのアトリビュートが、エンコーダの上に表示されませんでした。

* シーケンスの編集ウィンドウが開いていると、ディマー・エンコーダがシーケンスのマスターとして働いていました。

* Update ウィンドウがすでに開いている場合、ウィンドウ・エンコーダ3を回すと Update が行われてしまいました。

* コマンドライン情報を入力しているときに、ウィンドウ・エンコーダを回すと、入力内容が削除されていました。

* ページ変更時に、ネットワーク卓がモータ・フェーダを正しく操作できていませんでした。

* IfOutput が、デフォルト以外の値(例: Gobo)を持つフィクスチャもセレクトしていました。

* 新しいフィクスチャを追加する際に、プリセットの内容が削除されてしまってました。

* そのフォーム内でエフェクトを変更するとクラッシュする不具合を修正。

* ブラインドモードを有効にすると、Stage View で間違った出力が出ていました。

* Specialized Color ダイアログによって、RGB および CMY フィクスチャを同時に制御できるようになりました。

Version 1.0 2009-05-19 リリース

+ シーケンスのループ機能が有効になりました。

+ エクゼキュータ・デフォルトボタンとフェーダ割当が、デフォルトとして保存可能になりました。

+ Shaper ダイアログで、undo を含め、各フィクスチャの視点(POV)を記憶するようにしました。

+ Crazy Multitouch Color ダイアログで利用できる新たなカラー・ライブラリ。

+ Setup/Fixture Positions に、新しい項目列 "Id" (フィクスチャ/チャンネルId)を追加。

+ Crazy Multitouch Shaper ダイアログ: すべてのシェイパーをリセットする新しいリセットボタン。

+ Crazy Multitouch Color ダイアログの HSBカラーピッカーに、"fat finger" ボーダーを付けました。

+ Bitmap Effects Editor に操作性を改善するいくつかのメニューを追加。

+ GOTO および LOAD コマンドを実装。

+ COLOR キーワード・コマンドを実装。

+ FLIP コマンドを実装。構文: FLIP [flip番号] [オブジェクト・リスト]

+ IFOUTPUT コマンドを実装。構文: [+/-/INVERT] IFOUTPUT [AT 開始値 THRU 終了値] [+/-/INVERT] [オブジェクト・リスト]. [+/-/INVERT] セレクションモードは、コマンドの前でも途中でも好きな方に入力できます。grandMA 1 の構文では、セレクションモードはコマンドの途中でのみでした。

+ Setup → Console → Software Update にリリースノートおよびバージョン情報を追加。

+ グループ・セレクションが順序番号を持つようになりました。

+ Speed Group Master が、チェイサーやシーケンスに対して働くようになりました。

+ 画面選択付きの新しい Store View ダイアログ。

+ シーケンスのための 50個の Playback Special Master。

+ Split Fade および A/B Fade オプション・ボタン

+ Kill protect / Swap protect オプション・ボタン

+ ボタン割当に Swop 機能。

+ Update メニューを実装。

+ Off メニューを実装。Off タイミングはまだ利用できません。

+ オプションに Frame Color を追加。

+ Alt + Pause による Desk Lock 機能を追加

+ Setup メニューに、スクリーンセーバーのタイムとオフ設定を追加。

+ サブフィクスチャのパッチに対応しました。

+ grandMA2 RPU がネットワーク機能を持つようになりました。

* Crazy Multitouch Color ダイアログが、(最後にセレクトされた) RGB/CMYチャンネルを持たないフィクスチャを無視していました。

* Stage Wizard / Matrix Arrangement: Width → Horizontal Interval (= 幅/列数)、Height → Vertical Interval (= 高さ/行数)、新しい方向設定。

* Arrangement Wizard で最後に選択したアレンジメントを記憶するようにしました。

* Stage Wizard および Stagebar において、セレクションの順序を考慮するようにしました。

* Setup/Network に MA Network Control を追加。

* Sequence Executor シートを修正。